GM Tech II Saab card not find Bus ECU but GM card Solution

Car model and year:

’03 Saab 9-3

Tools I own:

I finally decided to order a clone from seller Obd2tool.com. It arrived this week (Monday), complete with all of the bits and pieces it was supposed to have, including a Saab card and a GM/Chev card.

I bought GM Tech2 $252 from obd2tool.com:

Package with Saab Card, GM Card , TIS2000 and Candi interface

shown as following package picture:

gm tech2

OS and computer configuration:

I have XP running in a VM on my Thinkpad with Windows 7 Pro, and TIS2000 is talking just fine to the Tech 2 via the USB to 232 adapter.

Operation:

1.Saab card can’t find any kind of Bus, or ECU

I tried connecting it to my wife’s ’03 9-3, and no matter what I do, it just can’t see anything on the car – it can’t find any kind of Bus, or ECU. The reason I finally ordered the thing was to marry a new ECU to the car. My cheapo card reader reads DTC’s and other info from the car just fine. I have tried it with version 143 and 148 (I re-flashed the one card with different versions) – same result, no bus detected.

The car was running, but going into limp home before I replaced the ECU…

2.GM card works fine on my Express van

When I pop out the Saab card, put in the GM card, the Car Diagnostic Tool Tech 2 works fine on my Express van – I was checking out all kinds of things, reading live data from the engine, playing with the radio, no problem.

Solution:

Used the Candi interface on my Express van – it worked.

5-1 5-2